Ajuda com mod que estou fazendo

    Compartilhe
    avatar
    ThePedro004
    Designer - Intermediário
    Designer - Intermediário

    Título : Trakinas Boy
    Mensagens : 3165
    Reputação : 131
    Desde : 13/10/2012
    Idade : 16
    Localização : Terra Mágica dos Poneys
    Link : MixMods.com.br

    Ajuda com mod que estou fazendo

    Mensagem por ThePedro004 em Qua 19 Dez 2012, 09:57

    Ae pessoal,blz,comecei a mecher com cleo (bem basicãão mesmo)
    Criei um script que coloca uma AK-47 dentro do emmet,pq so tem aquela pistolinha la e etc,em breve vou colocar mais armas,so que achei um problema muito comum :
    A Cada Save/Load cria um pickup novo,tem como resolver?Se tiver me ajudem plz.Lembrando que sou iniciante igual Natanael é inteligente trollface .Mas sei um poko de ingles(melhor da sala nessa materia)
    bem ta ai a source do code,se quiserem dar alguma sugestão ou alguma coisa que tiver errada no script comentem :
    Código:

    {$Cleo  .cs}
    thread "Arma"
    032B: $811 = create_weapon_pickup #AK47 group 15 ammo 100000 at 2445.61 -1971.133 13.54688
    0A93: end_custom_thread

    P.S EDIT Retirada


    Última edição por ThePedro004 em Qua 19 Dez 2012, 13:34, editado 4 vez(es)


    ____________________
    Configs:

    Processador : Intel Core 2 Quad Q8200 2.34 Ghz
    Memória RAM : 4GB DDR3
    Placa de Vídeo : GTX 750 1GB
    Sistema Operacional :  Windows 10 64 Bits Pro
    avatar
    Sávio
    Moderador
    Moderador

    Mensagens : 11923
    Reputação : 131
    Desde : 03/06/2012
    Idade : 20
    Localização : São João de Meriti, RJ

    Re: Ajuda com mod que estou fazendo

    Mensagem por Sávio em Qua 19 Dez 2012, 10:55

    eu acho ki essa parte thread "Arma" esta errada, deveria ser thread "Weapon"


    ____________________

    MEU PC::
    Monitor: Philips 196VL 19' polegadas
    CPU: Pentium Dual Core E5400 2,7GHzIntel Core I5 2310 2.9GHz *Inutilizado
    VGA: Xfx AMD Radeon HD 7770 1GB Core Edition                                            
    RAM:3,00GB Dual-Channel DDR2  6,00GB Dual-Channel DDR3 *Inutilizado
    MOB: Foxconn G31MXP (Socket 775)  PCWARE IPMH61R1 (Socket 1155)  Queimado
    PSU: Corsair 430W
    HDD: 500GB Seagate ST500DM002-1BD142
    HDD: 2000GB Seagate ST2000DM001-1E6164 Morreu
    OS: Windows 7 Ultimate 64-bit SP 1

    avatar
    ThePedro004
    Designer - Intermediário
    Designer - Intermediário

    Título : Trakinas Boy
    Mensagens : 3165
    Reputação : 131
    Desde : 13/10/2012
    Idade : 16
    Localização : Terra Mágica dos Poneys
    Link : MixMods.com.br

    Re: Ajuda com mod que estou fazendo

    Mensagem por ThePedro004 em Qua 19 Dez 2012, 11:00

    @Sávio escreveu:eu acho ki essa parte thread "Arma" esta errada, deveria ser thread "Weapon"
    Thread é só o nome do CS File.


    ____________________
    Configs:

    Processador : Intel Core 2 Quad Q8200 2.34 Ghz
    Memória RAM : 4GB DDR3
    Placa de Vídeo : GTX 750 1GB
    Sistema Operacional :  Windows 10 64 Bits Pro
    avatar
    EduardoJ.
    Mensagens Nível 5
    Mensagens Nível 5

    Título : Aspirante a matemático
    Mensagens : 607
    Reputação : 34
    Desde : 04/05/2012
    Idade : 20
    Localização : Anápolis - Goias

    Re: Ajuda com mod que estou fazendo

    Mensagem por EduardoJ. em Qua 19 Dez 2012, 11:16

    Thread pra começar, eh igual ao tuto do link:

    "Aqui você coloca o nome do seu mod", é o que eu mais ouço nesses tutoriais de merda, coloca o nome do seu mod é no meu piru!
    Esse opcode não vai servir para nada se você não for usar um desses opcodes para o script:
    Código:
    0459: end_thread_named 'INT'
    0ABA: end_custom_thread_named 'BENZIN'
    0AAA: 0@ = thread 'OTB' pointer

    Tutorial: http://brmodstudio.forumeiros.com/t258-comandos-simples-que-confudem

    Agora o poblem ai nao sei, numca usei pickup, tenta por o enable_thread_saving sei la
    :
    0A95: enable_thread_saving
    avatar
    ThePedro004
    Designer - Intermediário
    Designer - Intermediário

    Título : Trakinas Boy
    Mensagens : 3165
    Reputação : 131
    Desde : 13/10/2012
    Idade : 16
    Localização : Terra Mágica dos Poneys
    Link : MixMods.com.br

    Re: Ajuda com mod que estou fazendo

    Mensagem por ThePedro004 em Qua 19 Dez 2012, 11:25

    Yugi escreveu:Thread pra começar, eh igual ao tuto do link:

    "Aqui você coloca o nome do seu mod", é o que eu mais ouço nesses tutoriais de merda, coloca o nome do seu mod é no meu piru!
    Esse opcode não vai servir para nada se você não for usar um desses opcodes para o script:
    Código:
    0459: end_thread_named 'INT'
    0ABA: end_custom_thread_named 'BENZIN'
    0AAA: 0@ = thread 'OTB' pointer

    Tutorial: http://brmodstudio.forumeiros.com/t258-comandos-simples-que-confudem

    Agora o poblem ai nao sei, numca usei pickup, tenta por o enable_thread_saving sei la
    :
    0A95: enable_thread_saving
    vlw pela ajuda,mas nao adiantou,continua criando pickup a cada save/load


    ____________________
    Configs:

    Processador : Intel Core 2 Quad Q8200 2.34 Ghz
    Memória RAM : 4GB DDR3
    Placa de Vídeo : GTX 750 1GB
    Sistema Operacional :  Windows 10 64 Bits Pro
    avatar
    Fabio
    Programador - Avançado
    Programador - Avançado

    Título : CEO da Fabio's Gambiarra Industries
    Mensagens : 18631
    Reputação : 338
    Desde : 04/05/2012
    Idade : 20
    Localização : Reserva, Paraná, Brasil, América Latina, America do Sul, América, Planeta Terra, Sistema Solar, Via láctea, Universo
    Link : gtamodvicio.blogspot.com

    Re: Ajuda com mod que estou fazendo

    Mensagem por Fabio em Qua 19 Dez 2012, 12:36

    @ThePedro004 escreveu:
    Thread é só o nome do CS File.

    masoq???? serious? serious?


    Código:
    01C4: remove_references_to_object $355
    0108: destroy_object $355

    Pra que isso? Não tem nada a ver com o mod


    ____________________

    Modifico quase qualquer coisa.   :)
    ------------------>>>http://gtamodvicio.blogspot.com/<<<------------------

    Meu PC:
    Spoiler:

    Configurações PC:
    *Processador: Intel Core i7 4790K 4.00GHz LGA1150
    *Placa Mãe: GIGABYTE GA-H97M-D3H Intel (LGA1150)
    *HD: 1TB Seagate Barracuda 64MB Sata III 7200RPM (2x - RAID 0)
    *HD²: SAMSUNG M3 Externo USB 5400RPM 1TB
    *Placa de vídeo: Nvidia GTX660 2GB DDR5 192bit EVGA
    *RAM: 8GB DDR3 1600MHZ Kingston HYPER X BEAST (2x4GB)
    *Fonte: Corsair 600W Reais CX600M Modular - CP-9020060-WW (80 Plus Bronze)
    *Gabinete: Gabinete Raidmax Super Hurricane Branco - 248WB
    *Monitor: LG 23MP55HQ Full HD HDMI 23'
    avatar
    ThePedro004
    Designer - Intermediário
    Designer - Intermediário

    Título : Trakinas Boy
    Mensagens : 3165
    Reputação : 131
    Desde : 13/10/2012
    Idade : 16
    Localização : Terra Mágica dos Poneys
    Link : MixMods.com.br

    Re: Ajuda com mod que estou fazendo

    Mensagem por ThePedro004 em Qua 19 Dez 2012, 13:32

    @Fabio escreveu:
    @ThePedro004 escreveu:
    Thread é só o nome do CS File.

    masoq???? serious? serious?


    Código:
    01C4: remove_references_to_object $355
    0108: destroy_object $355

    Pra que isso? Não tem nada a ver com o mod
    @ThePedro004 escreveu:Thread é só o nome do CS File
    É,ai foi um momento FAIL,mas abaixo :
    Código:
    01C4: remove_references_to_object $355
    0108: destroy_object $355

    eu tentei remover a arma depois do save/load
    ja tirei pq nao funfou


    ____________________
    Configs:

    Processador : Intel Core 2 Quad Q8200 2.34 Ghz
    Memória RAM : 4GB DDR3
    Placa de Vídeo : GTX 750 1GB
    Sistema Operacional :  Windows 10 64 Bits Pro
    avatar
    Fabio
    Programador - Avançado
    Programador - Avançado

    Título : CEO da Fabio's Gambiarra Industries
    Mensagens : 18631
    Reputação : 338
    Desde : 04/05/2012
    Idade : 20
    Localização : Reserva, Paraná, Brasil, América Latina, America do Sul, América, Planeta Terra, Sistema Solar, Via láctea, Universo
    Link : gtamodvicio.blogspot.com

    Re: Ajuda com mod que estou fazendo

    Mensagem por Fabio em Qua 19 Dez 2012, 13:40

    Você está usando uma variável global para criar o pickup, e é um pickup generator, ou seja, toda hora que você inciar o jogo salvo o pickup tá lá, mantenha o enable_thread_saving no topo do código


    ____________________

    Modifico quase qualquer coisa.   :)
    ------------------>>>http://gtamodvicio.blogspot.com/<<<------------------

    Meu PC:
    Spoiler:

    Configurações PC:
    *Processador: Intel Core i7 4790K 4.00GHz LGA1150
    *Placa Mãe: GIGABYTE GA-H97M-D3H Intel (LGA1150)
    *HD: 1TB Seagate Barracuda 64MB Sata III 7200RPM (2x - RAID 0)
    *HD²: SAMSUNG M3 Externo USB 5400RPM 1TB
    *Placa de vídeo: Nvidia GTX660 2GB DDR5 192bit EVGA
    *RAM: 8GB DDR3 1600MHZ Kingston HYPER X BEAST (2x4GB)
    *Fonte: Corsair 600W Reais CX600M Modular - CP-9020060-WW (80 Plus Bronze)
    *Gabinete: Gabinete Raidmax Super Hurricane Branco - 248WB
    *Monitor: LG 23MP55HQ Full HD HDMI 23'
    avatar
    ThePedro004
    Designer - Intermediário
    Designer - Intermediário

    Título : Trakinas Boy
    Mensagens : 3165
    Reputação : 131
    Desde : 13/10/2012
    Idade : 16
    Localização : Terra Mágica dos Poneys
    Link : MixMods.com.br

    Re: Ajuda com mod que estou fazendo

    Mensagem por ThePedro004 em Qua 19 Dez 2012, 14:26

    @Fabio escreveu:Você está usando uma variável global para criar o pickup, e é um pickup generator, ou seja, toda hora que você inciar o jogo salvo o pickup tá lá, mantenha o enable_thread_saving no topo do código
    vlw :)
    EDIT: Bem agora que esse deu certo,tenho uma pergunta,scripters podem nao acreditar como sou noob mas...:
    Se eu quiser colocar mais armas eu tenho que colocar algum comando como wait ou jump?ou pode colocar de uma vez?


    ____________________
    Configs:

    Processador : Intel Core 2 Quad Q8200 2.34 Ghz
    Memória RAM : 4GB DDR3
    Placa de Vídeo : GTX 750 1GB
    Sistema Operacional :  Windows 10 64 Bits Pro
    avatar
    EduardoJ.
    Mensagens Nível 5
    Mensagens Nível 5

    Título : Aspirante a matemático
    Mensagens : 607
    Reputação : 34
    Desde : 04/05/2012
    Idade : 20
    Localização : Anápolis - Goias

    Re: Ajuda com mod que estou fazendo

    Mensagem por EduardoJ. em Qua 19 Dez 2012, 16:27

    @ThePedro004 escreveu:
    @Fabio escreveu:Você está usando uma variável global para criar o pickup, e é um pickup generator, ou seja, toda hora que você inciar o jogo salvo o pickup tá lá, mantenha o enable_thread_saving no topo do código
    vlw :)
    EDIT: Bem agora que esse deu certo,tenho uma pergunta,scripters podem nao acreditar como sou noob mas...:
    Se eu quiser colocar mais armas eu tenho que colocar algum comando como wait ou jump?ou pode colocar de uma vez?
    Tenta por um opcode em baixo do outro exemplo:

    CRIOU1
    CRIOU2
    CRIOU3
    CRIOU4
    etc...

    //Ignore os CRIOU ali eh como se fosse o opcode kk
    avatar
    ThePedro004
    Designer - Intermediário
    Designer - Intermediário

    Título : Trakinas Boy
    Mensagens : 3165
    Reputação : 131
    Desde : 13/10/2012
    Idade : 16
    Localização : Terra Mágica dos Poneys
    Link : MixMods.com.br

    Re: Ajuda com mod que estou fazendo

    Mensagem por ThePedro004 em Qua 19 Dez 2012, 16:34

    Yugi escreveu:
    @ThePedro004 escreveu:
    @Fabio escreveu:Você está usando uma variável global para criar o pickup, e é um pickup generator, ou seja, toda hora que você inciar o jogo salvo o pickup tá lá, mantenha o enable_thread_saving no topo do código
    vlw :)
    EDIT: Bem agora que esse deu certo,tenho uma pergunta,scripters podem nao acreditar como sou noob mas...:
    Se eu quiser colocar mais armas eu tenho que colocar algum comando como wait ou jump?ou pode colocar de uma vez?
    Tenta por um opcode em baixo do outro exemplo:

    CRIOU1
    CRIOU2
    CRIOU3
    CRIOU4
    etc...

    //Ignore os CRIOU ali eh como se fosse o opcode kk
    Eu estou pergutando se é pra fazer isso ou colocar outro codigo antes de cada "criou"


    ____________________
    Configs:

    Processador : Intel Core 2 Quad Q8200 2.34 Ghz
    Memória RAM : 4GB DDR3
    Placa de Vídeo : GTX 750 1GB
    Sistema Operacional :  Windows 10 64 Bits Pro
    avatar
    LINK/2012
    Programador - Avançado
    Programador - Avançado

    Título : Veterano
    Mensagens : 7857
    Reputação : 347
    Desde : 03/05/2012

    Re: Ajuda com mod que estou fazendo

    Mensagem por LINK/2012 em Qua 19 Dez 2012, 19:11

    q desgraça, vai ler meu tutorial, ja tou cansado do pessoal postando duvida aqui com codigo fudido que com certeza não leu uma palavra do meu tutorial pra ta uma fudidagem dessa, não vou perder meu tempo repetindo tudo que eu escrevi no tutorial aqui, mas porque porque? PORQUE EU FIZ O TUTORIAL PRA PORRA DO MUNDO NÃO PERGUNTAR A MESMA COSIAAAAAAAAA BUCETAAAAAAAAAA
    avatar
    ThePedro004
    Designer - Intermediário
    Designer - Intermediário

    Título : Trakinas Boy
    Mensagens : 3165
    Reputação : 131
    Desde : 13/10/2012
    Idade : 16
    Localização : Terra Mágica dos Poneys
    Link : MixMods.com.br

    Re: Ajuda com mod que estou fazendo

    Mensagem por ThePedro004 em Qua 19 Dez 2012, 20:17

    Da CLOSED,ate desisti de CLEO com o comentario acima. argh


    ____________________
    Configs:

    Processador : Intel Core 2 Quad Q8200 2.34 Ghz
    Memória RAM : 4GB DDR3
    Placa de Vídeo : GTX 750 1GB
    Sistema Operacional :  Windows 10 64 Bits Pro

    Conteúdo patrocinado

    Re: Ajuda com mod que estou fazendo

    Mensagem por Conteúdo patrocinado


      Data/hora atual: Qui 29 Jun 2017, 02:21